ggmap/rgadl

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

ggmap/rgadl

Abdoulaye SARR
I am using the command below and getting error message I don't understand
exactly what it is.
I hope some will help pass this step.
utmcoor <- SpatialPoints(cbind(OAK$UTM33_X, OAK$UTM33_Y),
+                          proj4string = CRS("+proj=utm +zone=33"))

Error: 'new_proj_and_gdal' is not an exported object from 'namespace:rgdal'

Kind regards,

Abdou

        [[alternative HTML version deleted]]

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo
Reply | Threaded
Open this post in threaded view
|

Re: ggmap/rgadl

Roger Bivand
Administrator
Please provide the output of sessionInfo(). You must have installed an unreleased development version of sp after having installed an unreleased development version of rgdal, then reinstalled a released version of rgdal. For rgdal also provide the output of the startup messages with PROJ and GDAL versions.

Roger Bivand
Norwegian School of Economics
Bergen, Norway
________________________________
From: R-sig-Geo <[hidden email]> on behalf of Abdoulaye Sarr <[hidden email]>
Sent: Wednesday, December 4, 2019 6:54:25 PM
To: r-sig-geo <[hidden email]>
Subject: [R-sig-Geo] ggmap/rgadl

I am using the command below and getting error message I don't understand
exactly what it is.
I hope some will help pass this step.
utmcoor <- SpatialPoints(cbind(OAK$UTM33_X, OAK$UTM33_Y),
+                          proj4string = CRS("+proj=utm +zone=33"))

Error: 'new_proj_and_gdal' is not an exported object from 'namespace:rgdal'

Kind regards,

Abdou

        [[alternative HTML version deleted]]

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo

        [[alternative HTML version deleted]]

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo
Roger Bivand
Department of Economics
Norwegian School of Economics
Helleveien 30
N-5045 Bergen, Norway
Reply | Threaded
Open this post in threaded view
|

Re: ggmap/rgadl

Abdoulaye SARR
rgdal: version: 1.4-8, (SVN revision 845)
 Geospatial Data Abstraction Library extensions to R successfully loaded
 Loaded GDAL runtime: GDAL 2.4.2, released 2019/06/28
 Path to GDAL shared files:
/Library/Frameworks/R.framework/Versions/3.6/Resources/library/rgdal/gdal
 GDAL binary built with GEOS: FALSE
 Loaded PROJ.4 runtime: Rel. 5.2.0, September 15th, 2018, [PJ_VERSION: 520]
 Path to PROJ.4 shared files:
/Library/Frameworks/R.framework/Versions/3.6/Resources/library/rgdal/proj
 Linking to sp version: 1.3-2

sessioninfo()
R version 3.6.1 (2019-07-05)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: macOS Mojave 10.14.6

Matrix products: default
BLAS:
/System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
LAPACK:
/Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libRlapack.dylib

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] parallel  stats     graphics  grDevices utils     datasets  methods
base

other attached packages:
 [1] rgdal_1.4-8          OpenStreetMap_0.3.4  magrittr_1.5
dplyr_0.8.3
 [5] gstat_2.0-3          ggmap_3.0.0.901      mapdata_2.3.0
 maptools_0.9-8
 [9] maps_3.3.0           MASS_7.3-51.4        climates_0.1-1.6
RANN_2.6.1
[13] rWBclimate_0.1.3     LaplacesDemon_16.1.1 inlabru_2.1.12.999
brinla_0.1.0
[17] INLA_19.09.03        reshape_0.8.8        lme4_1.1-21
 Matrix_1.2-17
[21] GGally_1.4.0         tidyr_1.0.0          plyr_1.8.4
ggplot2_3.2.1
[25] mgcv_1.8-31          nlme_3.1-142         lattice_0.20-38
 SpatialEpiApp_0.5
[29] devtools_2.2.1       usethis_1.5.1        glm2_1.2.1
raster_3.0-7
[33] sp_1.3-3



On Wed, Dec 4, 2019 at 6:23 PM Roger Bivand <[hidden email]> wrote:

> Please provide the output of sessionInfo(). You must have installed an
> unreleased development version of sp after having installed an unreleased
> development version of rgdal, then reinstalled a released version of rgdal.
> For rgdal also provide the output of the startup messages with PROJ and
> GDAL versions.
>
> Roger Bivand
> Norwegian School of Economics
> Bergen, Norway
> ------------------------------
> *From:* R-sig-Geo <[hidden email]> on behalf of
> Abdoulaye Sarr <[hidden email]>
> *Sent:* Wednesday, December 4, 2019 6:54:25 PM
> *To:* r-sig-geo <[hidden email]>
> *Subject:* [R-sig-Geo] ggmap/rgadl
>
> I am using the command below and getting error message I don't understand
> exactly what it is.
> I hope some will help pass this step.
> utmcoor <- SpatialPoints(cbind(OAK$UTM33_X, OAK$UTM33_Y),
> +                          proj4string = CRS("+proj=utm +zone=33"))
>
> Error: 'new_proj_and_gdal' is not an exported object from 'namespace:rgdal'
>
> Kind regards,
>
> Abdou
>
>         [[alternative HTML version deleted]]
>
> _______________________________________________
> R-sig-Geo mailing list
> [hidden email]
> https://stat.ethz.ch/mailman/listinfo/r-sig-geo
>

        [[alternative HTML version deleted]]

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo
Reply | Threaded
Open this post in threaded view
|

Re: ggmap/rgadl

Roger Bivand
Administrator
On Wed, 4 Dec 2019, Abdoulaye Sarr wrote:

> rgdal: version: 1.4-8, (SVN revision 845)
> Geospatial Data Abstraction Library extensions to R successfully loaded
> Loaded GDAL runtime: GDAL 2.4.2, released 2019/06/28
> Path to GDAL shared files:
> /Library/Frameworks/R.framework/Versions/3.6/Resources/library/rgdal/gdal
> GDAL binary built with GEOS: FALSE
> Loaded PROJ.4 runtime: Rel. 5.2.0, September 15th, 2018, [PJ_VERSION: 520]
> Path to PROJ.4 shared files:
> /Library/Frameworks/R.framework/Versions/3.6/Resources/library/rgdal/proj
> Linking to sp version: 1.3-2
>
> sessioninfo()
> R version 3.6.1 (2019-07-05)
> Platform: x86_64-apple-darwin15.6.0 (64-bit)
> Running under: macOS Mojave 10.14.6
>
> Matrix products: default
> BLAS:
> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
> LAPACK:
> /Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libRlapack.dylib
>
> locale:
> [1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8
>
> attached base packages:
> [1] parallel  stats     graphics  grDevices utils     datasets  methods
> base
>
> other attached packages:
> [1] rgdal_1.4-8          OpenStreetMap_0.3.4  magrittr_1.5
> dplyr_0.8.3
> [5] gstat_2.0-3          ggmap_3.0.0.901      mapdata_2.3.0
> maptools_0.9-8
> [9] maps_3.3.0           MASS_7.3-51.4        climates_0.1-1.6
> RANN_2.6.1
> [13] rWBclimate_0.1.3     LaplacesDemon_16.1.1 inlabru_2.1.12.999
> brinla_0.1.0
> [17] INLA_19.09.03        reshape_0.8.8        lme4_1.1-21
> Matrix_1.2-17
> [21] GGally_1.4.0         tidyr_1.0.0          plyr_1.8.4
> ggplot2_3.2.1
> [25] mgcv_1.8-31          nlme_3.1-142         lattice_0.20-38
> SpatialEpiApp_0.5
> [29] devtools_2.2.1       usethis_1.5.1        glm2_1.2.1
> raster_3.0-7
> [33] sp_1.3-3
    ^^^^^^^^^^^^

Please install sp 1.3-2 from CRAN. The 1.3-3 version is only available
from my github fork, and can currently only be installed (from source) if
rgdal >=1.5-1 is installed from R-Forge from source. It would be helpful
if you could say how you managed to install sp 1.3-3 and why and when you
did so.

When we are ready for GDAL >= 3 and PROJ >= 6, sp, rgdal and sf (with
stars and lwgeom) will be announced and released. We are not there yet.

Roger


>
>
>
> On Wed, Dec 4, 2019 at 6:23 PM Roger Bivand <[hidden email]> wrote:
>
>> Please provide the output of sessionInfo(). You must have installed an
>> unreleased development version of sp after having installed an unreleased
>> development version of rgdal, then reinstalled a released version of rgdal.
>> For rgdal also provide the output of the startup messages with PROJ and
>> GDAL versions.
>>
>> Roger Bivand
>> Norwegian School of Economics
>> Bergen, Norway
>> ------------------------------
>> *From:* R-sig-Geo <[hidden email]> on behalf of
>> Abdoulaye Sarr <[hidden email]>
>> *Sent:* Wednesday, December 4, 2019 6:54:25 PM
>> *To:* r-sig-geo <[hidden email]>
>> *Subject:* [R-sig-Geo] ggmap/rgadl
>>
>> I am using the command below and getting error message I don't understand
>> exactly what it is.
>> I hope some will help pass this step.
>> utmcoor <- SpatialPoints(cbind(OAK$UTM33_X, OAK$UTM33_Y),
>> +                          proj4string = CRS("+proj=utm +zone=33"))
>>
>> Error: 'new_proj_and_gdal' is not an exported object from 'namespace:rgdal'
>>
>> Kind regards,
>>
>> Abdou
>>
>>         [[alternative HTML version deleted]]
>>
>> _______________________________________________
>> R-sig-Geo mailing list
>> [hidden email]
>> https://stat.ethz.ch/mailman/listinfo/r-sig-geo
>>
>
> [[alternative HTML version deleted]]
>
> _______________________________________________
> R-sig-Geo mailing list
> [hidden email]
> https://stat.ethz.ch/mailman/listinfo/r-sig-geo
>

--
Roger Bivand
Department of Economics, Norwegian School of Economics,
Helleveien 30, N-5045 Bergen, Norway.
voice: +47 55 95 93 55; e-mail: [hidden email]
https://orcid.org/0000-0003-2392-6140
https://scholar.google.no/citations?user=AWeghB0AAAAJ&hl=en

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo
Roger Bivand
Department of Economics
Norwegian School of Economics
Helleveien 30
N-5045 Bergen, Norway
Reply | Threaded
Open this post in threaded view
|

Re: ggmap/rgadl

Abdoulaye SARR
Thank you, what I recall is the pack update I did after installing R 3.6.1!
(most recent action.
I now have another issue:
> longlatcoor   <- spTransform(utmcoor, CRS("+proj=longlat"))
> OAK$Long <- longlatcoor@coords[,1]
> OAK$Lat  <- longlatcoor@coords[,2]
>
> range(OAK$Long)
[1]  6.164666 18.653709
> range(OAK$Lat)
[1] 56.79080 60.40477
> glgmap   <- get_map(location = c(5, 55, 20, 62),
+                     #zoom = 10,
+                     source = "google",
+                     maptype= "terrain")
Bounding box given to Google - spatial extent only approximate.
Source :
https://maps.googleapis.com/maps/api/staticmap?center=58.5,12.5&zoom=6&size=640x640&scale=2&maptype=terrain&language=en-EN&key=[RKCJmE1PNJtH1c%20]
Error in aperm.default(map, c(2, 1, 3)) :
  invalid first argument, must be an array
In addition: Warning message:
In get_googlemap(center = location, zoom = zoom, maptype = maptype,  :
  HTTP 400 Bad Request

Abdou

On Wed, Dec 4, 2019 at 7:18 PM Roger Bivand <[hidden email]> wrote:

> On Wed, 4 Dec 2019, Abdoulaye Sarr wrote:
>
> > rgdal: version: 1.4-8, (SVN revision 845)
> > Geospatial Data Abstraction Library extensions to R successfully loaded
> > Loaded GDAL runtime: GDAL 2.4.2, released 2019/06/28
> > Path to GDAL shared files:
> > /Library/Frameworks/R.framework/Versions/3.6/Resources/library/rgdal/gdal
> > GDAL binary built with GEOS: FALSE
> > Loaded PROJ.4 runtime: Rel. 5.2.0, September 15th, 2018, [PJ_VERSION:
> 520]
> > Path to PROJ.4 shared files:
> > /Library/Frameworks/R.framework/Versions/3.6/Resources/library/rgdal/proj
> > Linking to sp version: 1.3-2
> >
> > sessioninfo()
> > R version 3.6.1 (2019-07-05)
> > Platform: x86_64-apple-darwin15.6.0 (64-bit)
> > Running under: macOS Mojave 10.14.6
> >
> > Matrix products: default
> > BLAS:
> >
> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
> > LAPACK:
> >
> /Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libRlapack.dylib
> >
> > locale:
> > [1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8
> >
> > attached base packages:
> > [1] parallel  stats     graphics  grDevices utils     datasets  methods
> > base
> >
> > other attached packages:
> > [1] rgdal_1.4-8          OpenStreetMap_0.3.4  magrittr_1.5
> > dplyr_0.8.3
> > [5] gstat_2.0-3          ggmap_3.0.0.901      mapdata_2.3.0
> > maptools_0.9-8
> > [9] maps_3.3.0           MASS_7.3-51.4        climates_0.1-1.6
> > RANN_2.6.1
> > [13] rWBclimate_0.1.3     LaplacesDemon_16.1.1 inlabru_2.1.12.999
> > brinla_0.1.0
> > [17] INLA_19.09.03        reshape_0.8.8        lme4_1.1-21
> > Matrix_1.2-17
> > [21] GGally_1.4.0         tidyr_1.0.0          plyr_1.8.4
> > ggplot2_3.2.1
> > [25] mgcv_1.8-31          nlme_3.1-142         lattice_0.20-38
> > SpatialEpiApp_0.5
> > [29] devtools_2.2.1       usethis_1.5.1        glm2_1.2.1
> > raster_3.0-7
> > [33] sp_1.3-3
>     ^^^^^^^^^^^^
>
> Please install sp 1.3-2 from CRAN. The 1.3-3 version is only available
> from my github fork, and can currently only be installed (from source) if
> rgdal >=1.5-1 is installed from R-Forge from source. It would be helpful
> if you could say how you managed to install sp 1.3-3 and why and when you
> did so.
>
> When we are ready for GDAL >= 3 and PROJ >= 6, sp, rgdal and sf (with
> stars and lwgeom) will be announced and released. We are not there yet.
>
> Roger
>
>
> >
> >
> >
> > On Wed, Dec 4, 2019 at 6:23 PM Roger Bivand <[hidden email]> wrote:
> >
> >> Please provide the output of sessionInfo(). You must have installed an
> >> unreleased development version of sp after having installed an
> unreleased
> >> development version of rgdal, then reinstalled a released version of
> rgdal.
> >> For rgdal also provide the output of the startup messages with PROJ and
> >> GDAL versions.
> >>
> >> Roger Bivand
> >> Norwegian School of Economics
> >> Bergen, Norway
> >> ------------------------------
> >> *From:* R-sig-Geo <[hidden email]> on behalf of
> >> Abdoulaye Sarr <[hidden email]>
> >> *Sent:* Wednesday, December 4, 2019 6:54:25 PM
> >> *To:* r-sig-geo <[hidden email]>
> >> *Subject:* [R-sig-Geo] ggmap/rgadl
> >>
> >> I am using the command below and getting error message I don't
> understand
> >> exactly what it is.
> >> I hope some will help pass this step.
> >> utmcoor <- SpatialPoints(cbind(OAK$UTM33_X, OAK$UTM33_Y),
> >> +                          proj4string = CRS("+proj=utm +zone=33"))
> >>
> >> Error: 'new_proj_and_gdal' is not an exported object from
> 'namespace:rgdal'
> >>
> >> Kind regards,
> >>
> >> Abdou
> >>
> >>         [[alternative HTML version deleted]]
> >>
> >> _______________________________________________
> >> R-sig-Geo mailing list
> >> [hidden email]
> >> https://stat.ethz.ch/mailman/listinfo/r-sig-geo
> >>
> >
> >       [[alternative HTML version deleted]]
> >
> > _______________________________________________
> > R-sig-Geo mailing list
> > [hidden email]
> > https://stat.ethz.ch/mailman/listinfo/r-sig-geo
> >
>
> --
> Roger Bivand
> Department of Economics, Norwegian School of Economics,
> Helleveien 30, N-5045 Bergen, Norway.
> voice: +47 55 95 93 55; e-mail: [hidden email]
> https://orcid.org/0000-0003-2392-6140
> https://scholar.google.no/citations?user=AWeghB0AAAAJ&hl=en
>

        [[alternative HTML version deleted]]

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo
Reply | Threaded
Open this post in threaded view
|

Re: ggmap/rgadl

Roger Bivand
Administrator
On Thu, 5 Dec 2019, Abdoulaye Sarr wrote:

> Thank you, what I recall is the pack update I did after installing R 3.6.1!
> (most recent action.

There is literally no path from sp 1.3-3 on my github fork to any CRAN
package update on OSX whatsoever.

> I now have another issue:
>> longlatcoor   <- spTransform(utmcoor, CRS("+proj=longlat"))
>> OAK$Long <- longlatcoor@coords[,1]
>> OAK$Lat  <- longlatcoor@coords[,2]
>>
>> range(OAK$Long)
> [1]  6.164666 18.653709
>> range(OAK$Lat)
> [1] 56.79080 60.40477
>> glgmap   <- get_map(location = c(5, 55, 20, 62),
> +                     #zoom = 10,
> +                     source = "google",
> +                     maptype= "terrain")
> Bounding box given to Google - spatial extent only approximate.
> Source :
> https://maps.googleapis.com/maps/api/staticmap?center=58.5,12.5&zoom=6&size=640x640&scale=2&maptype=terrain&language=en-EN&key=[RKCJmE1PNJtH1c%20]
> Error in aperm.default(map, c(2, 1, 3)) :
>  invalid first argument, must be an array
> In addition: Warning message:
> In get_googlemap(center = location, zoom = zoom, maptype = maptype,  :
>  HTTP 400 Bad Request

HTTP 400 Bad Request seems obvious. The Google API is aggressive and
largely unhelpful, you did not say which package provides get_map(), but I
see you using ggmap in the earlier sessionInfo(). Maybe raise an issue
with ggmap?

Roger

>
> Abdou
>
> On Wed, Dec 4, 2019 at 7:18 PM Roger Bivand <[hidden email]> wrote:
>
>> On Wed, 4 Dec 2019, Abdoulaye Sarr wrote:
>>
>>> rgdal: version: 1.4-8, (SVN revision 845)
>>> Geospatial Data Abstraction Library extensions to R successfully loaded
>>> Loaded GDAL runtime: GDAL 2.4.2, released 2019/06/28
>>> Path to GDAL shared files:
>>> /Library/Frameworks/R.framework/Versions/3.6/Resources/library/rgdal/gdal
>>> GDAL binary built with GEOS: FALSE
>>> Loaded PROJ.4 runtime: Rel. 5.2.0, September 15th, 2018, [PJ_VERSION:
>> 520]
>>> Path to PROJ.4 shared files:
>>> /Library/Frameworks/R.framework/Versions/3.6/Resources/library/rgdal/proj
>>> Linking to sp version: 1.3-2
>>>
>>> sessioninfo()
>>> R version 3.6.1 (2019-07-05)
>>> Platform: x86_64-apple-darwin15.6.0 (64-bit)
>>> Running under: macOS Mojave 10.14.6
>>>
>>> Matrix products: default
>>> BLAS:
>>>
>> /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
>>> LAPACK:
>>>
>> /Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libRlapack.dylib
>>>
>>> locale:
>>> [1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8
>>>
>>> attached base packages:
>>> [1] parallel  stats     graphics  grDevices utils     datasets  methods
>>> base
>>>
>>> other attached packages:
>>> [1] rgdal_1.4-8          OpenStreetMap_0.3.4  magrittr_1.5
>>> dplyr_0.8.3
>>> [5] gstat_2.0-3          ggmap_3.0.0.901      mapdata_2.3.0
>>> maptools_0.9-8
>>> [9] maps_3.3.0           MASS_7.3-51.4        climates_0.1-1.6
>>> RANN_2.6.1
>>> [13] rWBclimate_0.1.3     LaplacesDemon_16.1.1 inlabru_2.1.12.999
>>> brinla_0.1.0
>>> [17] INLA_19.09.03        reshape_0.8.8        lme4_1.1-21
>>> Matrix_1.2-17
>>> [21] GGally_1.4.0         tidyr_1.0.0          plyr_1.8.4
>>> ggplot2_3.2.1
>>> [25] mgcv_1.8-31          nlme_3.1-142         lattice_0.20-38
>>> SpatialEpiApp_0.5
>>> [29] devtools_2.2.1       usethis_1.5.1        glm2_1.2.1
>>> raster_3.0-7
>>> [33] sp_1.3-3
>>     ^^^^^^^^^^^^
>>
>> Please install sp 1.3-2 from CRAN. The 1.3-3 version is only available
>> from my github fork, and can currently only be installed (from source) if
>> rgdal >=1.5-1 is installed from R-Forge from source. It would be helpful
>> if you could say how you managed to install sp 1.3-3 and why and when you
>> did so.
>>
>> When we are ready for GDAL >= 3 and PROJ >= 6, sp, rgdal and sf (with
>> stars and lwgeom) will be announced and released. We are not there yet.
>>
>> Roger
>>
>>
>>>
>>>
>>>
>>> On Wed, Dec 4, 2019 at 6:23 PM Roger Bivand <[hidden email]> wrote:
>>>
>>>> Please provide the output of sessionInfo(). You must have installed an
>>>> unreleased development version of sp after having installed an
>> unreleased
>>>> development version of rgdal, then reinstalled a released version of
>> rgdal.
>>>> For rgdal also provide the output of the startup messages with PROJ and
>>>> GDAL versions.
>>>>
>>>> Roger Bivand
>>>> Norwegian School of Economics
>>>> Bergen, Norway
>>>> ------------------------------
>>>> *From:* R-sig-Geo <[hidden email]> on behalf of
>>>> Abdoulaye Sarr <[hidden email]>
>>>> *Sent:* Wednesday, December 4, 2019 6:54:25 PM
>>>> *To:* r-sig-geo <[hidden email]>
>>>> *Subject:* [R-sig-Geo] ggmap/rgadl
>>>>
>>>> I am using the command below and getting error message I don't
>> understand
>>>> exactly what it is.
>>>> I hope some will help pass this step.
>>>> utmcoor <- SpatialPoints(cbind(OAK$UTM33_X, OAK$UTM33_Y),
>>>> +                          proj4string = CRS("+proj=utm +zone=33"))
>>>>
>>>> Error: 'new_proj_and_gdal' is not an exported object from
>> 'namespace:rgdal'
>>>>
>>>> Kind regards,
>>>>
>>>> Abdou
>>>>
>>>>         [[alternative HTML version deleted]]
>>>>
>>>> _______________________________________________
>>>> R-sig-Geo mailing list
>>>> [hidden email]
>>>> https://stat.ethz.ch/mailman/listinfo/r-sig-geo
>>>>
>>>
>>>       [[alternative HTML version deleted]]
>>>
>>> _______________________________________________
>>> R-sig-Geo mailing list
>>> [hidden email]
>>> https://stat.ethz.ch/mailman/listinfo/r-sig-geo
>>>
>>
>> --
>> Roger Bivand
>> Department of Economics, Norwegian School of Economics,
>> Helleveien 30, N-5045 Bergen, Norway.
>> voice: +47 55 95 93 55; e-mail: [hidden email]
>> https://orcid.org/0000-0003-2392-6140
>> https://scholar.google.no/citations?user=AWeghB0AAAAJ&hl=en
>>
>
> [[alternative HTML version deleted]]
>
> _______________________________________________
> R-sig-Geo mailing list
> [hidden email]
> https://stat.ethz.ch/mailman/listinfo/r-sig-geo
>

--
Roger Bivand
Department of Economics, Norwegian School of Economics,
Helleveien 30, N-5045 Bergen, Norway.
voice: +47 55 95 93 55; e-mail: [hidden email]
https://orcid.org/0000-0003-2392-6140
https://scholar.google.no/citations?user=AWeghB0AAAAJ&hl=en

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo
Roger Bivand
Department of Economics
Norwegian School of Economics
Helleveien 30
N-5045 Bergen, Norway