Problems with using dismo package on HPC

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problems with using dismo package on HPC

Wall, Wade A ERDC-RDE-CERL-IL CIV
Hi all,

I am trying to use the dismo package on an HPC and am running into some problems. The code that I used worked fine until a few days ago, then I started getting the error message

Error in rgdal::getRasterData(con, offset = offs, region.dim = c(1, nc),  :
Failure during raster IO

Not sure how to proceed on this. The code works on my desktop computer, and like I said, worked until a few days ago on the HPC. I have read/write privileges to the outfolder location,  all the environmental layers are the same extent and resolution, and the spatial points are in the same coordinate system.

Any help would be greatly appreciated.
Wade

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo
Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problems with using dismo package on HPC

Michael Sumner-2
It might be because the file is absent.
You need to trace through from the top, what file path is passed to raster,
then try reading that directly with raster() and ensure the file exists.
It's possibly a raster object with a link to a file that no longer exists.
Raster is a complex polymorphic beast, and can be a thin brittle shell held
together by a file name, with no safety net.

If you don't have the original code it's harder, but also hard to help
without access to your system.

Cheers, Mike

On Wed, 21 Jun 2017, 07:30 Wall, Wade A ERDC-RDE-CERL-IL CIV, <
[hidden email]> wrote:

> Hi all,
>
> I am trying to use the dismo package on an HPC and am running into some
> problems. The code that I used worked fine until a few days ago, then I
> started getting the error message
>
> Error in rgdal::getRasterData(con, offset = offs, region.dim = c(1, nc),  :
> Failure during raster IO
>
> Not sure how to proceed on this. The code works on my desktop computer,
> and like I said, worked until a few days ago on the HPC. I have read/write
> privileges to the outfolder location,  all the environmental layers are the
> same extent and resolution, and the spatial points are in the same
> coordinate system.
>
> Any help would be greatly appreciated.
> Wade
>
> _______________________________________________
> R-sig-Geo mailing list
> [hidden email]
> https://stat.ethz.ch/mailman/listinfo/r-sig-geo
>
--
Dr. Michael Sumner
Software and Database Engineer
Australian Antarctic Division
203 Channel Highway
Kingston Tasmania 7050 Australia

        [[alternative HTML version deleted]]

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo
Loading...