New spdep version on CRAN depends on SparseM

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

New spdep version on CRAN depends on SparseM

Roger Bivand
Administrator
The new version of spdep on CRAN (0.3-5) depends on the SparseM package,
using its sparse determinant functions for fitting SAR models. This means
that users risk update.packages() failing if SparseM version >= 0.54 is
not installed first. This version provides robust sparse determinants, and
thus makes it possible to retire the previous sparse matrix code, which
has an unsolved memory bug - it will be retired at the next release.

This release also introduces the optional use of optim() rather than line
search using optimize(), which has worked without problem for some
BLAS/compiler combinations, but with problems for others. Use of optim()
will become necessary when trying to fit more than one spatial
coefficient, which is not yet possible.

Please report bugs/difficulties associated with migration to this new
series of spdep. The Windows binary should appear before long.

For users needing previous versions, for source see:

http://cran.r-project.org/src/contrib/Archive

or for Windows binary see:

http://cran.r-project.org/bin/windows/contrib/<R version>/last/

Since recent spdep versions have depended on R 2.0, knowing that you can
access older Windows binaries in the last/ folder is helpful for those who
cannot easily upgrade their R installation.

--
Roger Bivand
Economic Geography Section, Department of Economics, Norwegian School of
Economics and Business Administration, Breiviksveien 40, N-5045 Bergen,
Norway. voice: +47 55 95 93 55; fax +47 55 95 93 93
e-mail: Roger.Bivand at nhh.no



Roger Bivand
Department of Economics
Norwegian School of Economics
Helleveien 30
N-5045 Bergen, Norway