Landscape metrics: SDMTools. Error installation

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Landscape metrics: SDMTools. Error installation

juan jose mena
Dear all,

I am Juan José Mena, this is my first post but I need some help because I
need to compute patch and class metrics and the SDMTools package failed in
the installation. Does anyone know how to install it? Is there any
alternative?
thanks in advance

Juan

> install.packages('SDMTools',,'http://www.rforge.net/')
Error in install.packages : argument is missing, with no default
> library(SDMTools)
Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it
> library("SDMTools", lib.loc="C:/Program Files/R/R-3.1.3/library")
Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it
> install.packages("C:/Program Files/R/SDMTools_1.1-14.zip", repos = NULL)
package ‘SDMTools’ successfully unpacked and MD5 sums checked
Warning messages:
1: display list redraw incomplete
2: display list redraw incomplete
> library(SDMTools)
Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it

        [[alternative HTML version deleted]]

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo
Reply | Threaded
Open this post in threaded view
|

Re: Landscape metrics: SDMTools. Error installation

Sarah Goslee
>> install.packages('SDMTools',,'http://www.rforge.net/')
> Error in install.packages : argument is missing, with no default

I'd start by rerunning this command without the extra comma.




On Wed, Sep 16, 2015 at 11:14 AM, juan jose mena <[hidden email]> wrote:

> Dear all,
>
> I am Juan José Mena, this is my first post but I need some help because I
> need to compute patch and class metrics and the SDMTools package failed in
> the installation. Does anyone know how to install it? Is there any
> alternative?
> thanks in advance
>
> Juan
>
>> install.packages('SDMTools',,'http://www.rforge.net/')
> Error in install.packages : argument is missing, with no default
>> library(SDMTools)
> Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it
>> library("SDMTools", lib.loc="C:/Program Files/R/R-3.1.3/library")
> Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it
>> install.packages("C:/Program Files/R/SDMTools_1.1-14.zip", repos = NULL)
> package ‘SDMTools’ successfully unpacked and MD5 sums checked
> Warning messages:
> 1: display list redraw incomplete
> 2: display list redraw incomplete
>> library(SDMTools)
> Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it
>
>         [[alternative HTML version deleted]]
>
> _______________________________________________
> R-sig-Geo mailing list
> [hidden email]
> https://stat.ethz.ch/mailman/listinfo/r-sig-geo



--
Sarah Goslee
http://www.functionaldiversity.org

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo
Reply | Threaded
Open this post in threaded view
|

Re: Landscape metrics: SDMTools. Error installation

Shaun Walbridge
In reply to this post by juan jose mena
Try installing it from CRAN instead:

# R version 3.1.3 (2015-03-09) -- "Smooth Sidewalk"
# Platform: i386-w64-mingw32/i386 (32-bit)


install.packages("SDMTools")

# le package ‘SDMTools’ a été décompressé et les sommes MD5 ont été
vérifiées avec succés
--
Shaun Walbridge
GIS Developer



On 9/16/15, 11:14 AM, "R-sig-Geo on behalf of juan jose mena"
<[hidden email] on behalf of [hidden email]> wrote:

>Dear all,
>
>I am Juan José Mena, this is my first post but I need some help because I
>need to compute patch and class metrics and the SDMTools package failed in
>the installation. Does anyone know how to install it? Is there any
>alternative?
>thanks in advance
>
>Juan
>
>> install.packages('SDMTools',,'http://www.rforge.net/')
>Error in install.packages : argument is missing, with no default
>> library(SDMTools)
>Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it
>> library("SDMTools", lib.loc="C:/Program Files/R/R-3.1.3/library")
>Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it
>> install.packages("C:/Program Files/R/SDMTools_1.1-14.zip", repos = NULL)
>package ‘SDMTools’ successfully unpacked and MD5 sums checked
>Warning messages:
>1: display list redraw incomplete
>2: display list redraw incomplete
>> library(SDMTools)
>Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it
>
> [[alternative HTML version deleted]]
>
>_______________________________________________
>R-sig-Geo mailing list
>[hidden email]
>https://stat.ethz.ch/mailman/listinfo/r-sig-geo

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo
Reply | Threaded
Open this post in threaded view
|

Re: Landscape metrics: SDMTools. Error installation

juan jose mena
Thanks Alexandre for your tips, and all the others for the answers. I
updated all the packages and finally I installed from CRAN without doble
comma.
Now working,
thanks

2015-09-16 17:21 GMT+02:00 Shaun Walbridge <[hidden email]>:

> Try installing it from CRAN instead:
>
> # R version 3.1.3 (2015-03-09) -- "Smooth Sidewalk"
> # Platform: i386-w64-mingw32/i386 (32-bit)
>
>
> install.packages("SDMTools")
>
> # le package ‘SDMTools’ a été décompressé et les sommes MD5 ont été
> vérifiées avec succés
> --
> Shaun Walbridge
> GIS Developer
>
>
>
> On 9/16/15, 11:14 AM, "R-sig-Geo on behalf of juan jose mena"
> <[hidden email] on behalf of [hidden email]> wrote:
>
> >Dear all,
> >
> >I am Juan José Mena, this is my first post but I need some help because I
> >need to compute patch and class metrics and the SDMTools package failed in
> >the installation. Does anyone know how to install it? Is there any
> >alternative?
> >thanks in advance
> >
> >Juan
> >
> >> install.packages('SDMTools',,'http://www.rforge.net/')
> >Error in install.packages : argument is missing, with no default
> >> library(SDMTools)
> >Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it
> >> library("SDMTools", lib.loc="C:/Program Files/R/R-3.1.3/library")
> >Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it
> >> install.packages("C:/Program Files/R/SDMTools_1.1-14.zip", repos = NULL)
> >package ‘SDMTools’ successfully unpacked and MD5 sums checked
> >Warning messages:
> >1: display list redraw incomplete
> >2: display list redraw incomplete
> >> library(SDMTools)
> >Error: package ‘SDMTools’ was built before R 3.0.0: please re-install it
> >
> >       [[alternative HTML version deleted]]
> >
> >_______________________________________________
> >R-sig-Geo mailing list
> >[hidden email]
> >https://stat.ethz.ch/mailman/listinfo/r-sig-geo
>
>

        [[alternative HTML version deleted]]

_______________________________________________
R-sig-Geo mailing list
[hidden email]
https://stat.ethz.ch/mailman/listinfo/r-sig-geo